Visio Forward Engineer 1.0.6

Rating:        Based on 25 ratings
Reviewed:  20 reviews
Downloads: 55749
Change Set: 3476
Released: Mar 18, 2011
Updated: Mar 18, 2011 by MarioMajcica
Dev status: Stable Help Icon

Recommended Download

Application Visio Forward Engineer
application, 498K, uploaded Mar 18, 2011 - 55749 downloads

Release Notes

Installer problems were solved. Should be easier to install.

Reviews for this release

     
The error with the install is due to the fact that the installer is a 64bit installer and will not run on 32 bit. The zipped install files inside will run on 32 or 64 bit machine but installer is 64 bit. Get 64 bit machine and extract the files wihe setup.exe /C /T:C:\Temp where C:\Temp is existing directory. This should not have happened. Also the machine it was created on has IE9 RC.
by bpodfw on Jun 26, 2013 at 7:33 PM
     
Worked perfectly. This has saved me a lot of time indeed!
by d_claassens on Oct 21 at 10:10 AM
     
I've successfully installed and used this Visio Add-In today on a fresh platform. Windows 10 Enterprise, 64-bit Office 2016, 32-bit Visio 2010.
by codegurutoo on Aug 29 at 9:46 PM
     
Excelente para el desarrollo
by asegura96 on Feb 17, 2015 at 3:48 PM
     
Great Job, not flawless but does most of the dirty wasting time work.
by valarmorghulis on Oct 2, 2014 at 5:18 PM
     
Seems that little details are not carried over in the sql creation process. For example, many of my tables use a uniqueidentifier datatype as PK so I set the default to newid() and when the sql is created, the default isn't there. This is also true on certain datetime fields where I set the default to getdate().
by n2teeth on Mar 19, 2014 at 7:02 PM
     
Don`t wonrking inwindows xp
by rodolfosrwolf on Mar 11, 2014 at 7:55 PM
     
does not work with Windows 7 32 bits. Also xyre saids: "you have to rename the installation file to a .zip, extract it and run the .msi file". But @xyre: not at all :(
by mickro on Jul 9, 2013 at 5:13 AM
     
I need this
by gplzh on Jun 4, 2013 at 5:26 PM
     
I am getting the error. Setup.exe - the version of the file is not compatible with the version of Windows you're running. Check your computer's system information to see whethere you need an x86(32-bit) or x64 (64 bit)version of the program and then contact the software publisher. (OS Windows 7 Enterprise, 32-bit, applications Visio 2010 enterprise edition) Is there a solution?Please let meknow.
by ach22 on May 17, 2013 at 6:22 PM
     
saves me a lot of work, as we use only use visio for models thank you
by dalewith on May 13, 2013 at 8:31 PM
     
Thoroughly excellent solution that will save me a *pile* of work, thank you very much. Only thing I can't understand is why MS didn't build this or something similar into latest versions of Visio
by mharran on Dec 16, 2012 at 6:10 PM
     
It was a great product, but the 32 bits version it stopped working a few months ago. Did the programmer gave it a limited lifetime?
by sting01 on Aug 17, 2012 at 2:08 PM
     
Thanks, Alberto - finally able to generate SQL from Visio 2010 under Windows 7 - 64 bit!
by lre_int_de on Mar 16, 2012 at 12:08 PM
     
Both me and another employee (same model computer, same os Windows 7 Ent. 32-bit, same applications Visio 20101, etc) are getting the same error. V1.0.6 - the version of the file is not compatible with the version of Windows you're running. Check your computer's system information to see whethere you need an x86 or x64 version of the program and then contact the software publisher.
by celeste9519 on Mar 15, 2012 at 9:40 PM
     
I cannot install it on Win7 32bit. :( It says that it cannot be installed on my version of OS.
by ktrunin on Nov 12, 2011 at 12:22 PM
     
Excellent work! My entire team was able to use this plugin!
by qas1981 on Oct 17, 2011 at 3:22 PM
     
Great job! Worked like a charm for me. Thank you so much!
by sologut on Oct 5, 2011 at 7:00 PM
     
Hi there, I have identified 2 more issues with the add-in: 1. If a table does not have PK (only basic not unique index) the tool create this index like Clustered PK. 2. It does not recognize varchar(MAX) and similar datatypes. I am using SQL Server 2008 R2 (just in case). Can somebody fix it? Otherwise, it is impossible to use it because I cannot trust the add-in at the moment.
by AFomchenko on Feb 28, 2012 at 10:46 PM
     
@ ktrunin: you have to rename the installation file to a .zip, extract it and run the .msi file
by xyre on Jan 9, 2012 at 5:27 PM